Buffalo LinkStation LS-WV4.0TL/R1J 共有フォルダにアクセスできなくなったNASのデータ復旧

共有フォルダにアクセスできなくなった。とにかく診てもらいたい。

というお問い合わせ。
以前にも声を掛けていただいたことのある法人様からですね。たしか前もLinkStationだったような・・・。

お持ちいただいたいのは、やっぱりLinkStation。2TBが2台詰まったLS-WV4.0TL/R1Jというモデルです。

20180126_LS-WV4.0TLR1J_01

あれ?たしかこれ前も見たような。。。同じもの???
お客様のお話では前と同じだということでしたが・・・果たして!

NAS診断編

始めに断っておきますが、データ復旧系の作業は診断作業前にとにかく現状確保が最優先です。それをせずにむやみやたらに電源を入れて動かさないようにしましょう。

「え~今どうなってんでしょうね?気軽に電源ポチー」

というような修理屋が居たら激怒してやりましょう。そんくらいトラブル中のデータ装置は慎重に取り扱わないといけないんです。

と前置きした上で、電源ポチー(笑)

20180126_LS-WV4.0TLR1J_02

前面ランプはしっかりとエラーが点灯、というか点滅してますね。

これだけじゃまだどうなってるのか詳細が分からないので、急ごしらえのローカルネットワークを組んで状況を深堀していきます。

20180126_LS-WV4.0TLR1J_03

Buffalo謹製のNAS Navigatorではこのとおり。
目も当てられないような障害情報が並んでますな。。。

一応、確認の意味で共有フォルダの中を見ようとするも

20180126_LS-WV4.0TLR1J_04

アクセスできません

そりゃそうだ。。(笑)

大抵のNASってやつは、ハードディスクが2本入っていて、それぞれに同じデータが保存された上でどっちかが壊れても片方が生き残るからデータも生き残る、という仕組みなんすけども。

20180126_LS-WV4.0TLR1J_05

けども。けども!
なぜかお預かりしているLinkStationは、片方がぶっ壊れてて、もう片方が元気に0GBで動いているという状態。どうしてこうなった・・・。

20180126_LS-WV4.0TLR1J_06

この0GBの表示が何かの間違いであってくれぇ!という一縷の望みを託してのRAID再構築は

20180126_LS-WV4.0TLR1J_07

メッセージの出方からどう考えても無理スジなんだろうなぁとは思いながらも

20180126_LS-WV4.0TLR1J_08

やっぱりダメでした。
もう後がないぞリンクステーション!なんてことしてくれるんだバッファロー!!

20180126_LS-WV4.0TLR1J_09

※この診断作業は元ハードディスク2本とものクローンをしっかり確保した上で行ってます

NAS復旧編

この時点で生きたハードディスクからの楽なデータ復旧は無理なんだと自分に言い聞かせる作業を実施。自分を追い込み、そして腹をくくったところで、故障ディスク1を引っこ抜き

20180126_LS-WV4.0TLR1J_10

故障状況を把握し

20180126_LS-WV4.0TLR1J_11

XFSの上にパーティションが未知となっていることにさらに絶望してしまいましたが、なんとか4日かけてデータを復旧。

20180126_LS-WV4.0TLR1J_12

そこからさらにRAIDの再構築からデータの移し替えまで含めて計6日。NASの場合はデータ復旧作業以外のところで余分に日数が掛かるので、どうしても作業日数が長くなってしまいます。が!

ほぼすべてとなるおよそ1.3TB強のデータを取り戻すことができ作業完了。

20180126_LS-WV4.0TLR1J_13

これが2度目のデータ復旧依頼ですので、お客様にはバックアップ方法をお伝えしておきました。3度目が起こらなくて済むように。バックアップ設定とメール通知設定。ちゃんと設定してくれてたらいいんだけど・・・いいんだけどなぁ。

あー、あと。今回お預かりしたNASは前回のとは違ってたんですよね、やっぱし!答えは簡単、中に入ってるハードディスクが古いまんまでしたから。お客様もNASは2台あるとおっしゃっていたし。ということは、もう1台分もバックアップの設定を・・・やってくれていますように。

3度目も復活できる見込みなんて、ないんだからー!!

ご利用ありがとうございました。